logiciels:instal-digikam

Ceci est une ancienne révision du document !


J'ai dû rajouter le dépôt ppa/backport pour corriger des problèmes de dépendance.

Voici l'historique des commandes que j'ai validées sur un test de distribution linux-mint 17 MATE fraîchement installée et mise à jour


Installation des dépôts

sudo add-apt-repository ppa:kubuntu-ppa/backports

sudo apt-get update

sudo add-apt-repository ppa:msylwester/kubuntu-backports

sudo apt-get update

sudo add-apt-repository ppa:philip5/kubuntu-backports

sudo apt-get update

sudo add-apt-repository ppa:philip5/extra

sudo apt-get update

probablement un seul sudo apt-get update aurait suffit, mais j'étais prudent

sudo purge digikam

par précaution, nécessaire si déjà installé


sudo pluma /etc/apt/preferences.d/philip5-extra-ppa

cette commande ouvre pluma (l.éditeur de texte par défaut de ma distribution, si absent remplacer par le votre, par exemple gedit), y copier

Package: *

Pin: release o=LP-PPA-philip5-extra

Pin-Priority: 700

puis enregistrer et fermer



sudo pluma /etc/apt/preferences.d/philip5-kubuntu-backports-ppa

cette commande ouvre pluma, y copier

Package: *

Pin: release o=LP-PPA-philip5-kubuntu-backports

Pin-Priority: 700

puis enregistrer et fermer


sudo apt-get update

apt-cache policy digikam

sudo apt-get install digikam kipi-plugins

digikam

Dans mon test digikam démarre mal à cause de KDE (alors que dans distro il a bien démarré), j'ai résolu le problème simplement en installant okular une bonne application (lecture et annotation pdf), mais probablement j'aurais dû faire ce qui était conseillé à la fin de la documentation de ubuntu (https://doc.ubuntu-fr.org/digikam) : N'oubliez pas d'installer : Installez le paquet systemsettings. sinon les menus ne s’afficheront pas correctement.

sudo apt-get install okular

digikam

pour tester le lancement : banco ça marche


Il y a un petit problème avec les infobulles qui sont illisibles, ça se règle par le centre de contrôle de la distribution (apparence) en ajustant les couleurs


Voici les ppa installés pour digikam (copie d'écran dans le gestionnaire des sources), si vous ne voulez pas que les mises à jour se fassent par la suite, décochez les ppa dans le gestionnaire des sources

Si les kipi-plugins ne sont pas installés, le faire car ils apportent de nombreuses fonctions indispensables.

  • logiciels/instal-digikam.1457626914.txt.gz
  • Dernière modification: 2016/03/10 11:21
  • (modification externe)